#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ELSE\b(\n.*){1,}\bGO"
Local $sString = "BEGIN" & @CRLF & _
" something here!!!" & @CRLF & _
"END" & @CRLF & _
"ELSE" & @CRLF & _
" something here!!!" & @CRLF & _
" something here!!!" & @CRLF & _
" something here!!!" & @CRLF & _
" something here!!!" & @CRLF & _
"GO" & @CRLF & _
"" & @CRLF & _
"BEGIN" & @CRLF & _
" something here!!!" & @CRLF & _
"END" & @CRLF & _
"ELSE" & @CRLF & _
" something here!!!" & @CRLF & _
" something here!!!" & @CRLF & _
"GO" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")