using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ELSE\b(\n.*){1,}\bGO";
string input = @"BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
something here!!!
something here!!!
GO
BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
GO
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}