// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ELSE\b(\n.*){1,}\bGO").unwrap();
let string = "BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
something here!!!
something here!!!
GO
BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
GO
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}