import re
regex = re.compile(r"^ELSE\b(\n.*){1,}\bGO", flags=re.MULTILINE)
test_str = ("BEGIN\n"
" something here!!!\n"
"END\n"
"ELSE\n"
" something here!!!\n"
" something here!!!\n"
" something here!!!\n"
" something here!!!\n"
"GO\n\n"
"BEGIN\n"
" something here!!!\n"
"END\n"
"ELSE\n"
" something here!!!\n"
" something here!!!\n"
"GO\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")