re = /^ELSE\b(\n.*){1,}\bGO/m
str = 'BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
something here!!!
something here!!!
GO
BEGIN
something here!!!
END
ELSE
something here!!!
something here!!!
GO
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end