import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ELSE\\b(\\n.*){1,}\\bGO";
final String string = "BEGIN\n"
+ " something here!!!\n"
+ "END\n"
+ "ELSE\n"
+ " something here!!!\n"
+ " something here!!!\n"
+ " something here!!!\n"
+ " something here!!!\n"
+ "GO\n\n"
+ "BEGIN\n"
+ " something here!!!\n"
+ "END\n"
+ "ELSE\n"
+ " something here!!!\n"
+ " something here!!!\n"
+ "GO\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}