package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(PROJETO|PROTOCOLOS) *N(º|o) *[0-9.]+ *DE *\d+ DE \b.*?\b DE \d*\.`)
var str = `PROJETO Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROJETO No 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS No 1.100 DE 28 DE DEZEMBRO DE 2018.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}