import re
regex = re.compile(r"(PROJETO|PROTOCOLOS) *N(º|o) *[0-9.]+ *DE *\d+ DE \b.*?\b DE \d*\.")
test_str = ("PROJETO Nº 1.100 DE 28 DE DEZEMBRO DE 2018.\n"
"PROJETO No 1.100 DE 28 DE DEZEMBRO DE 2018.\n"
"PROTOCOLOS Nº 1.100 DE 28 DE DEZEMBRO DE 2018.\n"
"PROTOCOLOS No 1.100 DE 28 DE DEZEMBRO DE 2018.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")