const regex = new RegExp('(PROJETO|PROTOCOLOS) *N(º|o) *[0-9.]+ *DE *\\d+ DE \\b.*?\\b DE \\d*\\.', 'g')
const str = `PROJETO Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROJETO No 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS No 1.100 DE 28 DE DEZEMBRO DE 2018.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}