import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(PROJETO|PROTOCOLOS) *N(º|o) *[0-9.]+ *DE *\\d+ DE \\b.*?\\b DE \\d*\\.";
final String string = "PROJETO Nº 1.100 DE 28 DE DEZEMBRO DE 2018.\n"
+ "PROJETO No 1.100 DE 28 DE DEZEMBRO DE 2018.\n"
+ "PROTOCOLOS Nº 1.100 DE 28 DE DEZEMBRO DE 2018.\n"
+ "PROTOCOLOS No 1.100 DE 28 DE DEZEMBRO DE 2018.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}