re = /(PROJETO|PROTOCOLOS) *N(º|o) *[0-9.]+ *DE *\d+ DE \b.*?\b DE \d*\./
str = 'PROJETO Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROJETO No 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS No 1.100 DE 28 DE DEZEMBRO DE 2018.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end