use strict;
my $str = 'PROJETO Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROJETO No 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS Nº 1.100 DE 28 DE DEZEMBRO DE 2018.
PROTOCOLOS No 1.100 DE 28 DE DEZEMBRO DE 2018.';
my $regex = qr/(PROJETO|PROTOCOLOS) *N(º|o) *[0-9.]+ *DE *\d+ DE \b.*?\b DE \d*\./p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}