# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=(?:\b(?=\w*(?:fass|abeit))|\G(?<!^))\w*)a/ä/g;t' <<< "verfassen verabeit passen fassabeit"