#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=(?:\b(?=\w*(?:fass|abeit))|\G(?<!^))\w*)a"
Local $sString = "verfassen verabeit passen fassabeit"
Local $sSubst = "ä"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)