re = /(?<=(?:\b(?=\w*(?:fass|abeit))|\G(?<!^))\w*)a/
str = 'verfassen verabeit passen fassabeit'
subst = 'รค'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result