const regex = new RegExp('(?<=(?:\\b(?=\\w*(?:fass|abeit))|\\G(?<!^))\\w*)a', 'g')
const str = `verfassen verabeit passen fassabeit`;
const subst = `รค`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);