use strict;
my $str = 'verfassen verabeit passen fassabeit';
my $regex = qr/(?<=(?:\b(?=\w*(?:fass|abeit))|\G(?<!^))\w*)a/p;
my $subst = 'ä';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";