import re
regex = re.compile(r"(?<=(?:\b(?=\w*(?:fass|abeit))|\G(?<!^))\w*)a")
test_str = "verfassen verabeit passen fassabeit"
subst = "รค"
result = regex.sub(subst, test_str)
if result:
print(result)