using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?:\b(?=\w*(?:fass|abeit))|\G(?<!^))\w*)a";
string substitution = @"รค";
string input = @"verfassen verabeit passen fassabeit";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}