#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([-\d]+($|[^\.\d]))"
Local $sString = "Proceeds from disposal of investment properties 0 2,181 " & @CRLF & _
"Net cash inflows arising from acquisition of subsidiary 935 0 " & @CRLF & _
"companies 123 456 " & @CRLF & _
"Net cash used in investing activities -9,009 -4,238 " & @CRLF & _
"Net cash inflows arising from acquisition of subsidiary 935 0" & @CRLF & _
"companies"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")