using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([-\d]+($|[^\.\d]))";
string input = @"Proceeds from disposal of investment properties 0 2,181
Net cash inflows arising from acquisition of subsidiary 935 0
companies 123 456
Net cash used in investing activities -9,009 -4,238
Net cash inflows arising from acquisition of subsidiary 935 0
companies";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}