// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([-\d]+($|[^\.\d]))").unwrap();
let string = "Proceeds from disposal of investment properties 0 2,181
Net cash inflows arising from acquisition of subsidiary 935 0
companies 123 456
Net cash used in investing activities -9,009 -4,238
Net cash inflows arising from acquisition of subsidiary 935 0
companies";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}