use strict;
my $str = 'Proceeds from disposal of investment properties 0 2,181
Net cash inflows arising from acquisition of subsidiary 935 0
companies 123 456
Net cash used in investing activities -9,009 -4,238
Net cash inflows arising from acquisition of subsidiary 935 0
companies';
my $regex = qr/([-\d]+($|[^\.\d]))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}