package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([-\d]+($|[^\.\d]))`)
var str = `Proceeds from disposal of investment properties 0 2,181
Net cash inflows arising from acquisition of subsidiary 935 0
companies 123 456
Net cash used in investing activities -9,009 -4,238
Net cash inflows arising from acquisition of subsidiary 935 0
companies`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}