re = /([-\d]+($|[^\.\d]))/m
str = 'Proceeds from disposal of investment properties 0 2,181
Net cash inflows arising from acquisition of subsidiary 935 0
companies 123 456
Net cash used in investing activities -9,009 -4,238
Net cash inflows arising from acquisition of subsidiary 935 0
companies'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end