import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([-\\d]+($|[^\\.\\d]))";
final String string = "Proceeds from disposal of investment properties 0 2,181 \n"
+ "Net cash inflows arising from acquisition of subsidiary 935 0 \n"
+ "companies 123 456 \n"
+ "Net cash used in investing activities -9,009 -4,238 \n"
+ "Net cash inflows arising from acquisition of subsidiary 935 0\n"
+ "companies";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}