import Foundation
let pattern = #"([-\d]+($|[^\.\d]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Proceeds from disposal of investment properties 0 2,181
Net cash inflows arising from acquisition of subsidiary 935 0
companies 123 456
Net cash used in investing activities -9,009 -4,238
Net cash inflows arising from acquisition of subsidiary 935 0
companies
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)