using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S)\t[0-9]*\R\t+";
string substitution = @"$1";
string input = @" 9.1 The Euclidean Group in Two-Dimensional 152
Space E2
CHAPTER 10: THE LORENTZ AND POINCARÉ GROUPS,
AND SPACE-TIME SYMMETRIES 173
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}