const regex = /(\S)\t[0-9]*\R\t+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S)\\t[0-9]*\\R\\t+', 'g')
const str = ` 9.1 The Euclidean Group in Two-Dimensional 152
Space E2
CHAPTER 10: THE LORENTZ AND POINCARÉ GROUPS,
AND SPACE-TIME SYMMETRIES 173
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);