re = /(\S)\t[0-9]*\R\t+/
str = ' 9.1 The Euclidean Group in Two-Dimensional 152
Space E2
CHAPTER 10: THE LORENTZ AND POINCARÉ GROUPS,
AND SPACE-TIME SYMMETRIES 173
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result