#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\[(No Spoilers|S1 Spoilers|S1 Act 1 Spoilers|S1 Act 2 Spoilers|S1 Act 3 Spoilers|S2 Spoilers|S2 Act 1 Spoilers|S2 Act 2 Spoilers|S2 Act 3 Spoilers|Lore Spoilers)\]\s[^[]+|[^[]+)$"
Local $sString = "This Title Is Fine" & @CRLF & _
"[No Spoilers] This Title Is Fine" & @CRLF & _
"[S2 Act 2 Spoilers] This Title Is Fine" & @CRLF & _
"[Lore Spoilers] This Title Is Fine" & @CRLF & _
"[This Title] Is Not Fine" & @CRLF & _
"This Title Is Not Fine [No Spoilers]" & @CRLF & _
"[No Spoilers] This Title Is Not Fine [No Spoilers]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")