import re
regex = re.compile(r"^(?:\[(No Spoilers|S1 Spoilers|S1 Act 1 Spoilers|S1 Act 2 Spoilers|S1 Act 3 Spoilers|S2 Spoilers|S2 Act 1 Spoilers|S2 Act 2 Spoilers|S2 Act 3 Spoilers|Lore Spoilers)\]\s[^[]+|[^[]+)$", flags=re.MULTILINE)
test_str = ("This Title Is Fine\n"
"[No Spoilers] This Title Is Fine\n"
"[S2 Act 2 Spoilers] This Title Is Fine\n"
"[Lore Spoilers] This Title Is Fine\n"
"[This Title] Is Not Fine\n"
"This Title Is Not Fine [No Spoilers]\n"
"[No Spoilers] This Title Is Not Fine [No Spoilers]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")