$re = '/^(?:\[(No Spoilers|S1 Spoilers|S1 Act 1 Spoilers|S1 Act 2 Spoilers|S1 Act 3 Spoilers|S2 Spoilers|S2 Act 1 Spoilers|S2 Act 2 Spoilers|S2 Act 3 Spoilers|Lore Spoilers)\]\s[^[]+|[^[]+)$/m';
$str = 'This Title Is Fine
[No Spoilers] This Title Is Fine
[S2 Act 2 Spoilers] This Title Is Fine
[Lore Spoilers] This Title Is Fine
[This Title] Is Not Fine
This Title Is Not Fine [No Spoilers]
[No Spoilers] This Title Is Not Fine [No Spoilers]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);