import Foundation
let pattern = #"^(?:\[(No Spoilers|S1 Spoilers|S1 Act 1 Spoilers|S1 Act 2 Spoilers|S1 Act 3 Spoilers|S2 Spoilers|S2 Act 1 Spoilers|S2 Act 2 Spoilers|S2 Act 3 Spoilers|Lore Spoilers)\]\s[^[]+|[^[]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This Title Is Fine
[No Spoilers] This Title Is Fine
[S2 Act 2 Spoilers] This Title Is Fine
[Lore Spoilers] This Title Is Fine
[This Title] Is Not Fine
This Title Is Not Fine [No Spoilers]
[No Spoilers] This Title Is Not Fine [No Spoilers]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)