use strict;
my $str = 'This Title Is Fine
[No Spoilers] This Title Is Fine
[S2 Act 2 Spoilers] This Title Is Fine
[Lore Spoilers] This Title Is Fine
[This Title] Is Not Fine
This Title Is Not Fine [No Spoilers]
[No Spoilers] This Title Is Not Fine [No Spoilers]';
my $regex = qr/^(?:\[(No Spoilers|S1 Spoilers|S1 Act 1 Spoilers|S1 Act 2 Spoilers|S1 Act 3 Spoilers|S2 Spoilers|S2 Act 1 Spoilers|S2 Act 2 Spoilers|S2 Act 3 Spoilers|Lore Spoilers)\]\s[^[]+|[^[]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}