import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\[(No Spoilers|S1 Spoilers|S1 Act 1 Spoilers|S1 Act 2 Spoilers|S1 Act 3 Spoilers|S2 Spoilers|S2 Act 1 Spoilers|S2 Act 2 Spoilers|S2 Act 3 Spoilers|Lore Spoilers)\\]\\s[^[]+|[^[]+)$";
final String string = "This Title Is Fine\n"
+ "[No Spoilers] This Title Is Fine\n"
+ "[S2 Act 2 Spoilers] This Title Is Fine\n"
+ "[Lore Spoilers] This Title Is Fine\n"
+ "[This Title] Is Not Fine\n"
+ "This Title Is Not Fine [No Spoilers]\n"
+ "[No Spoilers] This Title Is Not Fine [No Spoilers]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}