// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\[(No Spoilers|S1 Spoilers|S1 Act 1 Spoilers|S1 Act 2 Spoilers|S1 Act 3 Spoilers|S2 Spoilers|S2 Act 1 Spoilers|S2 Act 2 Spoilers|S2 Act 3 Spoilers|Lore Spoilers)\]\s[^[]+|[^[]+)$").unwrap();
let string = "This Title Is Fine
[No Spoilers] This Title Is Fine
[S2 Act 2 Spoilers] This Title Is Fine
[Lore Spoilers] This Title Is Fine
[This Title] Is Not Fine
This Title Is Not Fine [No Spoilers]
[No Spoilers] This Title Is Not Fine [No Spoilers]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}