use strict;
my $str = '<div mark=\\"161\\" model=\\"2701\\"></div>
<div mark=\\"140\\" model=\\"2708\\"></div>
и тд';
my $regex = qr~<div mark=\\"\d+\\" model=\\"\d+\\"></div>~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";