// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<div mark=\\"\d+\\" model=\\"\d+\\"></div>"#).unwrap();
let string = "<div mark=\\\"161\\\" model=\\\"2701\\\"></div>
<div mark=\\\"140\\\" model=\\\"2708\\\"></div>
и тд";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}