re = /<div mark=\\"\d+\\" model=\\"\d+\\"><\/div>/m
str = '<div mark=\\"161\\" model=\\"2701\\"></div>
<div mark=\\"140\\" model=\\"2708\\"></div>
и тд'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result