# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div mark=\\\"\d+\\\" model=\\\"\d+\\\"></div>"
test_str = ("<div mark=\\\"161\\\" model=\\\"2701\\\"></div>\n"
"<div mark=\\\"140\\\" model=\\\"2708\\\"></div>\n"
"и тд")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.