# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/F(\w*?)o(\w*?)o(\w*?)B(\w*?)a(\w*?)r/$1$2$3$4$5/g;t' <<< "FottoBwaqwer
FottoBasarqrrFoowrBfgfhar"