// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"F(\w*?)o(\w*?)o(\w*?)B(\w*?)a(\w*?)r").unwrap();
let string = "FottoBwaqwer
FottoBasarqrrFoowrBfgfhar";
let substitution = "$1$2$3$4$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}