using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"F(\w*?)o(\w*?)o(\w*?)B(\w*?)a(\w*?)r";
string substitution = @"$1$2$3$4$5";
string input = @"FottoBwaqwer
FottoBasarqrrFoowrBfgfhar";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}