package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`F(\w*?)o(\w*?)o(\w*?)B(\w*?)a(\w*?)r`)
var str = `FottoBwaqwer
FottoBasarqrrFoowrBfgfhar`
var substitution = "$1$2$3$4$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}