#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "F(\w*?)o(\w*?)o(\w*?)B(\w*?)a(\w*?)r"
Local $sString = "FottoBwaqwer" & @CRLF & _
"FottoBasarqrrFoowrBfgfhar"
Local $sSubst = "$1$2$3$4$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)