re = /F(\w*?)o(\w*?)o(\w*?)B(\w*?)a(\w*?)r/
str = 'FottoBwaqwer
FottoBasarqrrFoowrBfgfhar'
subst = '$1$2$3$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result