use strict;
my $str = 'FottoBwaqwer
FottoBasarqrrFoowrBfgfhar';
my $regex = qr/F(\w*?)o(\w*?)o(\w*?)B(\w*?)a(\w*?)r/p;
my $subst = '$1$2$3$4$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";