import Foundation
let pattern = #"F(\w*?)o(\w*?)o(\w*?)B(\w*?)a(\w*?)r"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
FottoBwaqwer
FottoBasarqrrFoowrBfgfhar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)