# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.?)([fds]|(?<!t|^.)r)(.*)/$1$3$2/g;t' <<< "d45
f45
s66"